CRAN Package Check Results for Package HistData

Last updated on 2015-05-24 03:48:02.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.7-5 1.02 14.04 15.06 OK
r-devel-linux-x86_64-debian-gcc 0.7-5 0.96 13.32 14.28 OK
r-devel-linux-x86_64-fedora-clang 0.7-5 30.95 OK
r-devel-linux-x86_64-fedora-gcc 0.7-5 28.37 OK
r-devel-osx-x86_64-clang 0.7-5 30.53 OK
r-devel-windows-ix86+x86_64 0.7-5 4.00 24.00 28.00 OK
r-patched-linux-x86_64 0.7-5 1.15 14.52 15.67 OK
r-patched-solaris-sparc 0.7-5 178.40 OK
r-patched-solaris-x86 0.7-5 39.60 OK
r-release-linux-x86_64 0.7-5 1.02 14.63 15.65 OK
r-release-osx-x86_64-mavericks 0.7-5 OK
r-release-osx-x86_64-snowleopard 0.7-5 ERROR
r-release-windows-ix86+x86_64 0.7-5 4.00 27.00 31.00 OK
r-oldrel-windows-ix86+x86_64 0.7-5 5.00 26.00 31.00 OK

Check Details

Version: 0.7-5
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     ‘ggplot2’ ‘car’ ‘heplots’
Flavor: r-release-osx-x86_64-snowleopard

Version: 0.7-5
Check: Rd cross-references
Result: NOTE
    Packages unavailable to check Rd xrefs: ‘alr3’, ‘agridat’
Flavor: r-release-osx-x86_64-snowleopard

Version: 0.7-5
Check: examples
Result: ERROR
    Running examples in ‘HistData-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: Bowley
    > ### Title: Bowley's data on values of British and Irish trade, 1855-1899
    > ### Aliases: Bowley
    > ### Keywords: datasets
    >
    > ### ** Examples
    >
    > data(Bowley)
    >
    > # plot the data
    > with(Bowley,plot(Year, Value, type='b',
    + ylab="Value of British and Irish Exports",
    + main="Bowley's example of the method of smoothing curves"))
    >
    > # find moving averages-- use center alignment (requires width=ODD)
    > require(gtools, warn.conflicts=FALSE)
    Loading required package: gtools
    > mav3<-running(Bowley$Value, width=3, align="center")
    > mav5<-running(Bowley$Value, width=5, align="center")
    > mav9<-running(Bowley$Value, width=9, align="center")
    > lines(Bowley$Year[2:44], mav3, col='blue', lty=2)
    > lines(Bowley$Year[3:43], mav5, col='green3', lty=3)
    > lines(Bowley$Year[5:41], mav9, col='brown', lty=4)
    >
    > # add lowess smooth
    > lines(lowess(Bowley), col='red', lwd=2)
    >
    > require(ggplot2, warn.conflicts=FALSE)
    Loading required package: ggplot2
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘ggplot2’
    > qplot(Year,Value, data=Bowley)+geom_smooth()
    Error: could not find function "qplot"
    Execution halted
Flavor: r-release-osx-x86_64-snowleopard