CRAN Package Check Results for Package R330

Last updated on 2015-03-31 17:50:05.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0 1.22 24.08 25.29 NOTE
r-devel-linux-x86_64-debian-gcc 1.0 1.14 23.27 24.41 NOTE
r-devel-linux-x86_64-fedora-clang 1.0 49.39 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0 45.54 NOTE
r-devel-osx-x86_64-clang 1.0 52.01 NOTE
r-prerel-windows-ix86+x86_64 1.0 6.00 42.00 48.00 NOTE
r-prerel-linux-x86_64 1.0 1.14 25.62 26.76 NOTE
r-prerel-solaris-sparc 1.0 325.30 NOTE
r-prerel-solaris-x86 1.0 62.50 NOTE
r-release-linux-x86_64 1.0 1.46 28.10 29.57 NOTE
r-release-osx-x86_64-mavericks 1.0 NOTE
r-release-osx-x86_64-snowleopard 1.0 NOTE
r-release-windows-ix86+x86_64 1.0 7.00 49.00 56.00 NOTE
r-oldrel-windows-ix86+x86_64 1.0 7.00 45.00 52.00 NOTE

Check Details

Version: 1.0
Check: DESCRIPTION meta-information
Result: NOTE
    Malformed Description field: should contain one or more complete sentences.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-prerel-windows-ix86+x86_64, r-prerel-linux-x86_64, r-prerel-solaris-sparc, r-prerel-solaris-x86

Version: 1.0
Check: dependencies in R code
Result: NOTE
    'library' or 'require' call to ‘rgl’ which was already attached by Depends.
     Please remove these calls from your code.
    Packages in Depends field not imported from:
     ‘lattice’ ‘leaps’ ‘rgl’ ‘s20x’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-prerel-windows-ix86+x86_64, r-prerel-linux-x86_64, r-prerel-solaris-sparc, r-prerel-solaris-x86, r-release-linux-x86_64, r-release-windows-ix86+x86_64

Version: 1.0
Check: R code for possible problems
Result: NOTE
    allpossregs.formula: no visible global function definition for
     ‘regsubsets’
    allpossregs.lm: no visible global function definition for ‘regsubsets’
    reg3d: no visible global function definition for ‘rgl.open’
    reg3d: no visible global function definition for ‘rgl.bg’
    reg3d: no visible global function definition for ‘rgl.material’
    reg3d: no visible global function definition for ‘rgl.lines’
    reg3d: no visible global function definition for ‘rgl.spheres’
    reg3d: no visible global function definition for ‘rgl.surface’
    reg3d: no visible global function definition for ‘rgl.texts’
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-prerel-windows-ix86+x86_64, r-prerel-linux-x86_64, r-prerel-solaris-sparc, r-prerel-solaris-x86, r-release-linux-x86_64, r-release-osx-x86_64-mavericks, r-release-windows-ix86+x86_64

Version: 1.0
Check: dependencies in R code
Result: NOTE
    'library' or 'require' call to ‘rgl’ which was already attached by Depends.
     Please remove these calls from your code.
    Packages in Depends field not imported from:
     ‘lattice’ ‘leaps’ ‘rgl’ ‘s20x’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-release-osx-x86_64-mavericks, r-oldrel-windows-ix86+x86_64

Version: 1.0
Check: dependencies in R code
Result: NOTE
    ‘library’ or ‘require’ call to ‘rgl’ which was already attached by Depends.
     Please remove these calls from your code.
    Packages in Depends field not imported from:
     ‘lattice’ ‘leaps’ ‘rgl’ ‘s20x’
     These packages need to be imported from for the case when
     this namespace is loaded but not attached.
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-release-osx-x86_64-snowleopard