CRAN Package Check Results for Package RSAP

Last updated on 2014-10-31 16:47:50.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.9 5.84 5.84 NOTE --install=no
r-devel-linux-x86_64-debian-gcc 0.9 5.77 5.77 NOTE --install=no
r-devel-linux-x86_64-fedora-clang 0.9 11.31 NOTE --install=no
r-devel-linux-x86_64-fedora-gcc 0.9 10.12 NOTE --install=no
r-patched-linux-x86_64 0.9 5.85 5.85 NOTE --install=no
r-release-linux-ix86 0.9 8.34 8.34 NOTE --install=no
r-release-linux-x86_64 0.9 5.75 5.75 NOTE --install=no
r-release-osx-x86_64-mavericks 0.9 ERROR
r-release-osx-x86_64-snowleopard 0.9 ERROR
r-oldrel-windows-ix86+x86_64 0.9 0.00 2.00 2.00 ERROR

Check Details

Version: 0.9
Flags: --install=no
Check: top-level files
Result: NOTE
    Non-standard files/directories found at top level:
     ‘install_dependencies.R’ ‘install_dependencies.sh’ ‘run_tests.R’
     ‘send.sh’
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.9
Flags: --install=no
Check: dependencies in R code
Result: NOTE
    'library' or 'require' calls to packages already attached by Depends:
     ‘reshape’ ‘yaml’
     Please remove these calls from your code.
    Packages in Depends field not imported from:
     ‘reshape’ ‘yaml’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-linux-x86_64, r-release-linux-ix86, r-release-linux-x86_64

Version: 0.9
Flags: --install=no
Check: Rd line widths
Result: NOTE
    Rd file 'RSAPConnect.Rd':
     \examples lines wider than 100 characters:
     con <- RSAPConnect(ashost="nplhost", sysnr="42", client="001", user="developer", passwd="developer", lang="EN", trace="1", lcheck="1")
    
    Rd file 'RSAPExecInfoQuery.Rd':
     \examples lines wider than 100 characters:
     res <- RSAPExecInfoQuery(con, "0D_NW_T01", "20120716",chars=list("0D_NW_SORG", "0D_NW_PROD"), kfigures=list("0D_NW_NETV"))
    
    Rd file 'RSAPReadCube.Rd':
     \examples lines wider than 100 characters:
     res <- RSAPReadCube(con, "0D_NW_T01", "20120716",chars=list("0D_NW_SORG", "0D_NW_PROD"), kfigures=list("0D_NW_NETV"))
    
    Rd file 'RSAPReadTable.Rd':
     \examples lines wider than 100 characters:
     res <- RSAPReadTable(con, "SFLIGHTS2", options=list("CARRID = 'AA'"), fields=list('CARRID', 'CONNID', 'FLDATE', 'PRICE'))
    
    These lines will be truncated in the PDF manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-linux-x86_64, r-release-linux-x86_64

Version: 0.9
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavors: r-release-osx-x86_64-mavericks, r-release-osx-x86_64-snowleopard, r-oldrel-windows-ix86+x86_64