CRAN Package Check Results for Package Rdrools

Last updated on 2017-11-24 14:49:59 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.2 2.06 64.42 66.48 OK
r-devel-linux-x86_64-debian-gcc 1.0.2 1.68 58.08 59.75 OK
r-devel-linux-x86_64-fedora-clang 1.0.2 44.45 OK
r-devel-linux-x86_64-fedora-gcc 1.0.2 44.49 OK
r-devel-windows-ix86+x86_64 1.0.2 7.00 46.00 53.00 OK
r-patched-linux-x86_64 1.0.2 2.10 66.66 68.76 OK
r-patched-solaris-x86 1.0.2 58.90 OK
r-release-linux-x86_64 1.0.2 2.14 67.62 69.77 OK
r-release-windows-ix86+x86_64 1.0.2 6.00 60.00 66.00 OK
r-release-osx-x86_64 1.0.2 OK
r-oldrel-windows-ix86+x86_64 1.0.2 6.00 47.00 53.00 OK
r-oldrel-osx-x86_64 1.0.2 ERROR

Check Details

Version: 1.0.2
Check: examples
Result: ERROR
    Running examples in ‘Rdrools-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: Rdrools-package
    > ### Title: A Rules Engine for R based on the popular Java based Drools
    > ### Aliases: Rdrools-package Rdrools
    > ### Keywords: rulesSession runRules Rdrools
    >
    > ### ** Examples
    >
    > library(Rdrools)
    > data(class)
    > data(rules)
    > input.columns<-c('name', 'class', 'grade', 'email')
    > output.columns<-c('address', 'subject', 'body')
    > rules.session<-rulesSession(rules, input.columns, output.columns)
    Error in .jnew("org/math/r/drools/DroolsService", rules, input.columns, :
     java.lang.UnsupportedClassVersionError: org/math/r/drools/DroolsService : Unsupported major.minor version 51.0
    Calls: rulesSession -> .jnew -> .External
    Execution halted
Flavor: r-oldrel-osx-x86_64