CRAN Package Check Results for Package RnavGraph

Last updated on 2015-05-25 23:47:35.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.1.8 3.48 63.48 66.96 OK
r-devel-linux-x86_64-debian-gcc 0.1.8 3.59 62.20 65.79 OK
r-devel-linux-x86_64-fedora-clang 0.1.8 142.93 OK
r-devel-linux-x86_64-fedora-gcc 0.1.8 137.20 OK
r-devel-osx-x86_64-clang 0.1.8 129.39 OK
r-devel-windows-ix86+x86_64 0.1.8 14.00 115.00 129.00 OK
r-patched-linux-x86_64 0.1.8 3.58 62.68 66.27 OK
r-patched-solaris-sparc 0.1.8 993.80 OK
r-patched-solaris-x86 0.1.8 217.20 OK
r-release-linux-x86_64 0.1.8 3.60 62.68 66.28 OK
r-release-osx-x86_64-mavericks 0.1.8 WARN
r-release-osx-x86_64-snowleopard 0.1.8 ERROR
r-release-windows-ix86+x86_64 0.1.8 16.00 125.00 141.00 OK
r-oldrel-windows-ix86+x86_64 0.1.8 19.00 136.00 155.00 OK

Check Details

Version: 0.1.8
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: ‘RDRToolbox’ ‘vegan’
Flavor: r-release-osx-x86_64-mavericks

Version: 0.1.8
Check: running R code from vignettes
Result: WARN
    Errors in running code in vignettes:
    when running code in ‘RnavGraph.Rnw’
     ...
    > p.digits <- digits[, sel]
    
    > ng.i.digits <- ng_image_array_gray("USPS Handwritten Digits",
    + p.digits, 16, 16, invert = TRUE, img_in_row = FALSE)
    
    > library(vegan)
    
     When sourcing ‘RnavGraph.R’:
    Error: there is no package called ‘vegan’
    Execution halted
Flavor: r-release-osx-x86_64-mavericks

Version: 0.1.8
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    Loading required package: tcltk
    Loading required package: graph
    
    RnavGraph Version 0.1.8
    Please read the package vignette. Use vignette("RnavGraph").
    
    
    Loading required package: grid
    
    Error: processing vignette 'RnavGraph.Rnw' failed with diagnostics:
     chunk 59
    Error in library(vegan) : there is no package called ‘vegan’
    Execution halted
Flavor: r-release-osx-x86_64-mavericks

Version: 0.1.8
Check: package dependencies
Result: ERROR
    Package required but not available: ‘graph’
    
    Packages suggested but not available for checking:
     ‘PairViz’ ‘RDRToolbox’ ‘Rgraphviz’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-osx-x86_64-snowleopard