CRAN Package Check Results for Package TSdata

Last updated on 2014-12-18 11:50:20.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2013.9-1 0.86 6.45 7.31 OK --no-vignettes
r-devel-linux-x86_64-debian-gcc 2013.9-1 0.82 6.28 7.09 OK --no-vignettes
r-devel-linux-x86_64-fedora-clang 2013.9-1 15.61 OK --no-vignettes
r-devel-linux-x86_64-fedora-gcc 2013.9-1 15.09 OK --no-vignettes
r-devel-osx-x86_64-clang 2013.9-1 12.14 NOTE --no-vignettes
r-devel-windows-ix86+x86_64 2013.9-1 5.00 11.00 16.00 NOTE --no-vignettes
r-patched-linux-x86_64 2013.9-1 0.83 6.33 7.16 OK --no-vignettes
r-patched-solaris-sparc 2013.9-1 55.90 NOTE --no-vignettes
r-patched-solaris-x86 2013.9-1 16.40 NOTE --no-vignettes
r-release-linux-ix86 2013.9-1 1.18 6.92 8.10 OK --no-vignettes
r-release-linux-x86_64 2013.9-1 0.81 6.64 7.45 OK --no-vignettes
r-release-osx-x86_64-mavericks 2013.9-1 ERROR
r-release-windows-ix86+x86_64 2013.9-1 3.00 11.00 14.00 NOTE --no-vignettes
r-oldrel-windows-ix86+x86_64 2013.9-1 3.00 12.00 15.00 NOTE --no-vignettes

Check Details

Version: 2013.9-1
Flags: --no-vignettes
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘TSMySQL’
Flavors: r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 2013.9-1
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     ‘TSPostgreSQL’ ‘TSMySQL’ ‘TSodbc’
Flavor: r-release-osx-x86_64-mavericks

Version: 2013.9-1
Check: running R code from vignettes
Result: ERROR
    Errors in running code in vignettes:
    when running code in ‘Guide.Stex’
     ...
    Loading required package: TSjson
    Loading required package: findpython
    
    > cansim <- TSconnect("json", dbname = "cansim")
    Error in find_python_cmd(minimum_version = minimum_version, maximum_version = maximum_version, :
     Couldn't find a sufficient Python binary. If you haven't installed the Python dependency yet please do so. If you have but it isn't on the system path (as is default on Windows) please add it to path or set options('python_cmd'='/path/to/binary') or set the PYTHON, PYTHON2, or PYTHON3 environmental variables. Python must be at least version 2.6 Python must be at most version 2.9 Python must have access to the modules: sys, re, urllib2, csv, mechanize, json
    
     When sourcing ‘Guide.R’:
    Error: Python 2 and modules urllib2, re, csv, mechanize, and json must be installed
    Execution halted
Flavor: r-release-osx-x86_64-mavericks