CRAN Package Check Results for Package agridat

Last updated on 2014-04-24 17:49:39.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.8 4.74 83.31 88.04 NOTE
r-devel-linux-x86_64-debian-gcc 1.8 4.53 86.23 90.76 NOTE
r-devel-linux-x86_64-fedora-clang 1.8 187.66 NOTE
r-devel-linux-x86_64-fedora-gcc 1.8 178.76 NOTE
r-devel-osx-x86_64-clang 1.8 133.52 NOTE
r-devel-osx-x86_64-gcc 1.8 ERROR
r-devel-windows-ix86+x86_64 1.8 13.00 124.00 137.00 NOTE
r-patched-linux-x86_64 1.8 4.60 86.11 90.72 NOTE
r-patched-solaris-sparc 1.8 998.30 NOTE
r-patched-solaris-x86 1.8 218.80 NOTE
r-release-linux-ix86 1.8 8.00 128.00 136.00 NOTE
r-release-linux-x86_64 1.8 4.86 81.84 86.70 NOTE
r-release-osx-x86_64-mavericks 1.8 ERROR
r-release-windows-ix86+x86_64 1.8 13.00 130.00 143.00 NOTE
r-oldrel-windows-ix86+x86_64 1.8 10.00 1.00 11.00 ERROR

Check Details

Version: 1.8
Check: dependencies in R code
Result: NOTE
    Packages in Depends field not imported from:
     ‘lattice’ ‘reshape2’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-osx-x86_64-gcc, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-mavericks, r-release-windows-ix86+x86_64

Version: 1.8
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking:
     ‘agricolae’ ‘car’ ‘corrgram’ ‘FrF2’ ‘gstat’ ‘HH’ ‘latticeExtra’
Flavor: r-devel-osx-x86_64-gcc

Version: 1.8
Check: examples
Result: ERROR
    Running examples in ‘agridat-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: beall.borers
    > ### Title: Corn borer infestation under four treatments
    > ### Aliases: beall.borers
    > ### Keywords: datasets
    >
    > ### ** Examples
    >
    > dat <- beall.borers
    >
    > # Add 0 frequencies
    > dat0 <- expand.grid(borers=0:26, treat=c('T1','T2','T3','T4'))
    > dat0 <- merge(dat0,dat, all=TRUE)
    > dat0$freq[is.na(dat0$freq)] <- 0
    >
    > # Expand to individual (non-aggregated) counts for each hill
    > dd <- data.frame(borers = rep(dat0$borers, times=dat0$freq),
    + treat = rep(dat0$treat, times=dat0$freq))
    >
    > library(lattice)
    > histogram(~borers|treat, dd, type='count', breaks=0:27-.5,
    + layout=c(1,4), main="beall.borers", xlab="Borers per hill")
    >
    >
    > library(MASS)
    > m1 <- glm.nb(borers~0+treat, data=dd)
    > # Bliss, table 3, presents treatment means, which are matched by:
    > exp(coef(m1)) # 4.033333 3.166667 1.483333 1.508333
     treatT1 treatT2 treatT3 treatT4
    4.033333 3.166667 1.483333 1.508333
    > # Bliss gives treatment values k = c(1.532,1.764,1.333,1.190).
    > # The mean of these is 1.45, similar to this across-treatment estimate
    > m1$theta # 1.47
    [1] 1.47145
    >
    >
    > # Plot observed and expected distributions for treatment 2
    > xx <- 0:26
    > yy <- dnbinom(0:26, mu=3.17, size=1.47)*120 # estimates are from glm.nb
    > library(latticeExtra)
    Error in library(latticeExtra) :
     there is no package called ‘latticeExtra’
    Execution halted
Flavor: r-devel-osx-x86_64-gcc

Version: 1.8
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘gstat’
Flavor: r-release-osx-x86_64-mavericks

Version: 1.8
Check: examples
Result: ERROR
    Running examples in ‘agridat-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: mercer.wheat.uniformity
    > ### Title: Mercer and Hall's uniformity trial of wheat in 1910
    > ### Aliases: mercer.wheat.uniformity
    >
    > ### ** Examples
    >
    > dat <- mercer.wheat.uniformity
    >
    > require('lattice')
    > desplot(grain ~ col*row, dat, main="mercer.wheat.uniformity")
    >
    > densityplot(~grain, data=dat)
    >
    > xyplot(straw ~ grain, data=dat, type=c('p','r'), main="mercer.wheat.uniformity - regression")
    >
    > # require(hexbin)
    > # hexbinplot(straw ~ grain, data=dat)
    >
    > require(sp)
    Loading required package: sp
    > require(gstat)
    Loading required package: gstat
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘gstat’
    > plot.wid <- 2.5
    > plot.len <- 3.2
    > nr <- length(unique(dat$row))
    > nc <- length(unique(dat$col))
    >
    > xy <- expand.grid(x = seq(plot.wid/2, by=plot.wid, length=nc),
    + y = seq(plot.len/2, by=plot.len, length=nr))
    > dat.sp <- dat
    > coordinates(dat.sp) <- xy
    >
    > # heatmap
    > spplot(dat.sp, zcol = "grain", cuts=8,
    + cex = 1.6,
    + col.regions = bpy.colors(8),
    + main = "Grain yield", key.space = "right")
    >
    > # variogram
    > vg <- variogram(grain ~ 1, dat.sp, cutoff = plot.wid * 10, width = plot.wid)
    Error: could not find function "variogram"
    Execution halted
Flavor: r-release-osx-x86_64-mavericks

Version: 1.8
Check: whether package can be installed
Result: ERROR
    Installation failed.
    See 'd:/Rcompile/CRANpkg/local/3.0/agridat.Rcheck/00install.out' for details.
Flavor: r-oldrel-windows-ix86+x86_64