CRAN Package Check Results for Package coin

Last updated on 2014-04-19 11:48:48.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0-23 3.41 118.37 121.78 OK
r-devel-linux-x86_64-debian-gcc 1.0-23 3.45 117.90 121.35 OK
r-devel-linux-x86_64-fedora-clang 1.0-23 239.66 OK
r-devel-linux-x86_64-fedora-gcc 1.0-23 233.97 OK
r-devel-macosx-x86_64-clang 1.0-23 192.29 OK
r-devel-macosx-x86_64-gcc 1.0-23 WARN
r-devel-windows-ix86+x86_64 1.0-23 14.00 194.00 208.00 OK
r-patched-linux-x86_64 1.0-23 3.44 117.75 121.20 OK
r-patched-solaris-sparc 1.0-23 1602.50 OK
r-patched-solaris-x86 1.0-23 280.00 OK
r-release-linux-ix86 1.0-23 8.00 184.00 192.00 OK
r-release-linux-x86_64 1.0-23 3.41 118.26 121.68 OK
r-release-windows-ix86+x86_64 1.0-23 18.00 207.00 225.00 OK
r-oldrel-windows-ix86+x86_64 1.0-23 14.00 212.00 226.00 OK

Check Details

Version: 1.0-23
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: ‘multcomp’ ‘vcd’
    
    Package which this enhances but not available for checking: ‘Biobase’
Flavor: r-devel-macosx-x86_64-gcc

Version: 1.0-23
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘Biobase’
Flavor: r-devel-macosx-x86_64-gcc

Version: 1.0-23
Check: running R code from vignettes
Result: WARNING
    Errors in running code in vignettes:
    when running code in ‘coin_implementation.Rnw’
     ...
    Male <5000 1 1 2 1
     5000-15000 0 3 5 1
     15000-25000 0 0 7 3
     >25000 0 1 9 6
    
    > library("vcd")
    
     When sourcing ‘coin_implementation.R’:
    Error: there is no package called ‘vcd’
    Execution halted
Flavor: r-devel-macosx-x86_64-gcc

Version: 1.0-23
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    Loading required package: coin
    Loading required package: survival
    Loading required package: splines
    Warning in sub(object$syntax$docexpr, val, chunk[pos[1L]]) :
     argument 'replacement' has length > 1 and only the first element will be used
    Loading required package: Biobase
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘Biobase’
    Loading required package: multcomp
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘multcomp’
    Loading required package: multcomp
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘multcomp’
    
    Error: processing vignette 'coin_implementation.Rnw' failed with diagnostics:
     chunk 28 (label = js-plot)
    Error in library("vcd") : there is no package called ‘vcd’
    Execution halted
Flavor: r-devel-macosx-x86_64-gcc