CRAN Package Check Results for Package doRNG

Last updated on 2017-09-22 02:47:28.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.6.6 0.84 60.92 61.76 OK --no-tests
r-devel-linux-x86_64-debian-gcc 1.6.6 1.20 60.39 61.59 OK --no-tests
r-devel-linux-x86_64-fedora-clang 1.6.6 88.44 OK
r-devel-linux-x86_64-fedora-gcc 1.6.6 87.56 OK
r-devel-windows-ix86+x86_64 1.6.6 4.00 91.00 95.00 OK
r-patched-linux-x86_64 1.6.6 0.97 60.82 61.79 OK --no-tests
r-patched-solaris-x86 1.6.6 130.20 OK
r-release-linux-x86_64 1.6.6 0.85 61.19 62.04 OK --no-tests
r-release-windows-ix86+x86_64 1.6.6 3.00 93.00 96.00 OK
r-release-osx-x86_64 1.6.6 WARN
r-oldrel-windows-ix86+x86_64 1.6.6 3.00 79.00 82.00 OK
r-oldrel-osx-x86_64 1.6.6 NOTE

Check Details

Version: 1.6.6
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: ‘doMPI’ ‘devtools’
Flavor: r-release-osx-x86_64

Version: 1.6.6
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘doMPI’
Flavors: r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 1.6.6
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning: running command 'kpsewhich framed.sty' had status 1
    Warning in test_latex_pkg("framed", system.file("misc", "framed.sty", package = "knitr")) :
     unable to find LaTeX package 'framed'; will use a copy from knitr
    Error in texi2dvi(file = file, pdf = TRUE, clean = clean, quiet = quiet, :
     Running 'texi2dvi' on 'doRNG-unitTests.tex' failed.
    LaTeX errors:
    ! LaTeX Error: File `vmargin.sty' not found.
    
    Type X to quit or <RETURN> to proceed,
    or enter new name. (Default extension: sty)
    
    ! Emergency stop.
    <read *>
    
    l.58 \setmargrb
     {0.75in}{0.75in}{0.75in}{0.75in}^^M
    ! ==> Fatal error occurred, no output PDF file produced!
    Calls: buildVignettes -> texi2pdf -> texi2dvi
    Execution halted
Flavor: r-release-osx-x86_64

Version: 1.6.6
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘doMPI’
Flavor: r-oldrel-osx-x86_64