CRAN Package Check Results for Package gganimate

Last updated on 2019-03-20 03:53:17 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.2 9.58 250.50 260.08 OK
r-devel-linux-x86_64-debian-gcc 1.0.2 8.16 183.79 191.95 OK
r-devel-linux-x86_64-fedora-clang 1.0.2 298.05 OK
r-devel-linux-x86_64-fedora-gcc 1.0.2 287.37 OK
r-devel-windows-ix86+x86_64 1.0.2 27.00 307.00 334.00 OK
r-patched-linux-x86_64 1.0.2 8.52 243.45 251.97 OK
r-patched-solaris-x86 1.0.2 109.40 ERROR
r-release-linux-x86_64 1.0.2 7.86 245.56 253.42 OK
r-release-windows-ix86+x86_64 1.0.2 15.00 319.00 334.00 OK
r-release-osx-x86_64 1.0.2 OK
r-oldrel-windows-ix86+x86_64 1.0.2 17.00 331.00 348.00 OK
r-oldrel-osx-x86_64 1.0.2 OK

Check Details

Version: 1.0.2
Check: package dependencies
Result: NOTE
    Packages suggested but not available for checking: ‘av’ ‘gifski’
Flavor: r-patched-solaris-x86

Version: 1.0.2
Check: tests
Result: ERROR
     Running ‘testthat.R’ [8s/12s]
    Running the tests in ‘tests/testthat.R’ failed.
    Complete output:
     > library(testthat)
     > library(gganimate)
     Loading required package: ggplot2
     >
     > test_check("gganimate")
     ── 1. Error: anim_save overwrites existing files (@test-anim_save.R#8) ────────
     The `gifski_renderer()` is selected by default but requires the gifski
     package to be installed. Either install gifski or use another renderer.
     See `?renderers` for a list of available ones.
     1: capture.output({
     a1 <- animate(p, nframes = 2)
     a2 <- animate(p, nframes = 3)
     }) at testthat/test-anim_save.R:8
     2: evalVis(expr)
     3: withVisible(eval(expr, pf))
     4: eval(expr, pf)
     5: eval(expr, pf)
     6: animate(p, nframes = 2)
     7: animate.gganim(p, nframes = 2)
     8: prepare_args(nframes = nframes, fps = fps, duration = duration, detail = detail,
     renderer = renderer, device = device, ref_frame = ref_frame, start_pause = start_pause,
     end_pause = end_pause, rewind = rewind, ...)
     9: renderer %?% chunk_args$renderer %||% getOption("gganimate.renderer", gifski_renderer())
     10: getOption("gganimate.renderer", gifski_renderer())
     11: gifski_renderer()
     12: stop("The `gifski_renderer()` is selected by default but requires the gifski\n",
     "package to be installed. Either install gifski or use another renderer.\n",
     "See `?renderers` for a list of available ones.", call. = FALSE)
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     OK: 6 SKIPPED: 0 FAILED: 1
     1. Error: anim_save overwrites existing files (@test-anim_save.R#8)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-patched-solaris-x86

Version: 1.0.2
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 51-57 (gganimate.Rmd)
    Error: processing vignette 'gganimate.Rmd' failed with diagnostics:
    The `gifski_renderer()` is selected by default but requires the gifski
    package to be installed. Either install gifski or use another renderer.
    See `?renderers` for a list of available ones.
    Execution halted
Flavor: r-patched-solaris-x86