CRAN Package Check Results for Package gsmaRt

Last updated on 2014-04-24 21:47:41.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0 3.77 50.14 53.91 NOTE
r-devel-linux-x86_64-debian-gcc 1.0 4.06 50.40 54.47 NOTE
r-devel-linux-x86_64-fedora-clang 1.0 112.91 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0 107.18 NOTE
r-devel-osx-x86_64-clang 1.0 92.20 NOTE
r-devel-osx-x86_64-gcc 1.0 ERROR
r-devel-windows-ix86+x86_64 1.0 11.00 65.00 76.00 NOTE
r-patched-linux-x86_64 1.0 3.88 48.55 52.43 NOTE
r-patched-solaris-sparc 1.0 600.00 NOTE
r-patched-solaris-x86 1.0 158.60 NOTE
r-release-linux-ix86 1.0 6.00 84.00 90.00 NOTE
r-release-linux-x86_64 1.0 3.96 50.27 54.23 NOTE
r-release-osx-x86_64-mavericks 1.0 ERROR
r-release-osx-x86_64-snowleopard 1.0 NOTE
r-release-windows-ix86+x86_64 1.0 12.00 64.00 76.00 NOTE
r-oldrel-windows-ix86+x86_64 1.0 13.00 81.00 94.00 NOTE

Check Details

Version: 1.0
Check: package dependencies
Result: NOTE
    Depends: includes the non-default packages:
     ‘GEOquery’ ‘R2HTML’ ‘qvalue’ ‘rgl’ ‘scatterplot3d’ ‘xtable’ ‘limma’
    Adding so many packages to the search path is excessive and importing
    selectively is preferable.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-snowleopard, r-release-windows-ix86+x86_64

Version: 1.0
Check: dependencies in R code
Result: NOTE
    'library' or 'require' calls to packages already attached by Depends:
     ‘GEOquery’ ‘R2HTML’ ‘limma’ ‘qvalue’ ‘rgl’ ‘scatterplot3d’ ‘xtable’
     Please remove these calls from your code.
    Packages in Depends field not imported from:
     ‘GEOquery’ ‘R2HTML’ ‘limma’ ‘qvalue’ ‘rgl’ ‘scatterplot3d’ ‘xtable’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-snowleopard, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.0
Check: for old-style vignette sources
Result: NOTE
    Vignette sources only in ‘inst/doc’:
     ‘gsmaRt.Rnw’
    A ‘vignettes’ directory is required as from R 3.1.0
    and these will not be indexed nor checked
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-snowleopard, r-release-windows-ix86+x86_64

Version: 1.0
Check: Rd line widths
Result: NOTE
    Rd file 'analyse.gsmart.Rd':
     \usage lines wider than 90 characters:
     analyse.gsmart(X, response, gs.list, nrot = 1000, tests = c("W", "G"), one.sided = FALSE, verbose = FALSE)
    
    These lines will be truncated in the PDF manual.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.0
Check: package dependencies
Result: ERROR
    Packages required but not available: ‘GEOquery’ ‘qvalue’ ‘limma’
    
    Depends: includes the non-default packages:
     ‘GEOquery’ ‘R2HTML’ ‘qvalue’ ‘rgl’ ‘scatterplot3d’ ‘xtable’ ‘limma’
    Adding so many packages to the search path is excessive and importing
    selectively is preferable.
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-devel-osx-x86_64-gcc, r-release-osx-x86_64-mavericks

Version: 1.0
Check: for old-style vignette sources
Result: NOTE
    Vignette sources only in 'inst/doc':
     'gsmaRt.Rnw'
    A 'vignettes' directory will be required as from R 3.1.0
Flavor: r-oldrel-windows-ix86+x86_64