CRAN Package Check Results for Package latticeDensity

Last updated on 2014-04-21 12:43:19.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.0.7 5.83 73.94 79.77 NOTE
r-devel-linux-x86_64-debian-gcc 1.0.7 5.77 74.14 79.91 NOTE
r-devel-linux-x86_64-fedora-clang 1.0.7 184.78 NOTE
r-devel-linux-x86_64-fedora-gcc 1.0.7 180.59 NOTE
r-devel-osx-x86_64-clang 1.0.7 140.85 NOTE
r-devel-osx-x86_64-gcc 1.0.7 ERROR
r-devel-windows-ix86+x86_64 1.0.7 15.00 109.00 124.00 NOTE
r-patched-linux-x86_64 1.0.7 5.86 73.24 79.09 NOTE
r-patched-solaris-sparc 1.0.7 946.90 NOTE
r-patched-solaris-x86 1.0.7 227.50 NOTE
r-release-linux-x86_64 1.0.7 5.79 74.18 79.97 NOTE
r-release-osx-x86_64-mavericks 1.0.7 ERROR
r-release-osx-x86_64-snowleopard 1.0.7 NOTE
r-release-windows-ix86+x86_64 1.0.7 21.00 105.00 126.00 NOTE
r-oldrel-windows-ix86+x86_64 1.0.7 18.00 104.00 122.00 NOTE

Check Details

Version: 1.0.7
Check: dependencies in R code
Result: NOTE
    'library' or 'require' calls to packages already attached by Depends:
     ‘spam’ ‘spatstat’ ‘spdep’ ‘splancs’
     Please remove these calls from your code.
    Packages in Depends field not imported from:
     ‘spam’ ‘spatstat’ ‘spdep’ ‘splancs’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-x86_64, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.0.7
Check: package dependencies
Result: ERROR
    Packages required but not available: ‘spdep’ ‘spam’
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-devel-osx-x86_64-gcc

Version: 1.0.7
Check: package dependencies
Result: ERROR
    Package required but not available: ‘spdep’
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-release-osx-x86_64-mavericks

Version: 1.0.7
Check: dependencies in R code
Result: NOTE
    'library' or 'require' calls to packages already attached by Depends:
     'spam' 'spatstat' 'spdep' 'splancs'
     Please remove these calls from your code.
    See the information on DESCRIPTION files in the chapter 'Creating R
    packages' of the 'Writing R Extensions' manual.
Flavor: r-release-osx-x86_64-snowleopard