CRAN Package Check Results for Package mapmisc

Last updated on 2014-08-28 08:48:57.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.9.4 3.27 129.19 132.46 OK
r-devel-linux-x86_64-debian-gcc 0.9.4 3.20 129.73 132.93 OK
r-devel-linux-x86_64-fedora-clang 0.9.4 308.29 OK
r-devel-linux-x86_64-fedora-gcc 0.9.4 302.55 OK
r-devel-osx-x86_64-clang 0.9.4 226.88 OK
r-devel-windows-ix86+x86_64 0.9.4 10.00 133.00 143.00 OK
r-patched-linux-x86_64 0.9.4 3.48 139.49 142.97 OK
r-patched-solaris-sparc 0.9.4 1633.80 NOTE
r-patched-solaris-x86 0.9.4 407.30 NOTE
r-release-linux-ix86 0.9.4 4.02 180.41 184.44 OK
r-release-linux-x86_64 0.9.4 3.44 137.09 140.54 OK
r-release-osx-x86_64-mavericks 0.9.4 ERROR
r-release-osx-x86_64-snowleopard 0.9.4 OK
r-release-windows-ix86+x86_64 0.9.4 9.00 119.00 128.00 OK
r-oldrel-windows-ix86+x86_64 0.9.4 8.00 125.00 133.00 OK

Check Details

Version: 0.9.4
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    libpng warning: Application was compiled with png.h from libpng-1.6.10
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    libpng warning: Application was compiled with png.h from libpng-1.6.10
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    libpng warning: Application was compiled with png.h from libpng-1.6.10
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    libpng warning: Application was compiled with png.h from libpng-1.6.10
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    libpng warning: Application was compiled with png.h from libpng-1.6.10
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    libpng warning: Application was compiled with png.h from libpng-1.6.10
    libpng warning: Application is running with png.c from libpng-1.2.50
    libpng error: Incompatible libpng version in application and library
    make: Fatal error in reader: Makefile, line 2: Unexpected end of line seen
    Current working directory /home/ripley/R/packages/tests32/mapmisc.Rcheck/vign_test/mapmisc/vignettes
    Error in buildVignettes(dir = "/home/ripley/R/packages/tests32/mapmisc.Rcheck/vign_test/mapmisc") :
     running 'make' failed
    Execution halted
Flavor: r-patched-solaris-sparc

Version: 0.9.4
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    make: Fatal error in reader: Makefile, line 2: Unexpected end of line seen
    Current working directory /home/ripley/R/packages/tests32/mapmisc.Rcheck/vign_test/mapmisc/vignettes
    Error in buildVignettes(dir = "/home/ripley/R/packages/tests32/mapmisc.Rcheck/vign_test/mapmisc") :
     running 'make' failed
    Execution halted
Flavor: r-patched-solaris-x86

Version: 0.9.4
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘rgdal’
Flavor: r-release-osx-x86_64-mavericks

Version: 0.9.4
Check: Rd cross-references
Result: NOTE
    Package unavailable to check Rd xrefs: ‘OpenStreetMap’
Flavor: r-release-osx-x86_64-mavericks

Version: 0.9.4
Check: examples
Result: ERROR
    Running examples in ‘mapmisc-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: scaleBar
    > ### Title: Map with scale bar
    > ### Aliases: scaleBar map.new insetMap
    >
    > ### ** Examples
    >
    >
    > Npoints = 20
    > myPoints = SpatialPointsDataFrame(
    + .20*cbind(runif(Npoints), runif(Npoints)),
    + data=data.frame(y1=c(NA, rnorm(Npoints-1)),
    + y2=c(sample(1:4, Npoints-1,replace=TRUE), NA)),
    + proj4string=CRS("+init=epsg:4326")
    + )
    >
    > ## Not run:
    > ##D mymap = openmap(myPoints)
    > ## End(Not run)
    >
    > breaks = c(-100, -1, 1, Inf)
    > thecol = c('red','orange','blue')
    >
    >
    > map.new(myPoints)
    > ## Not run:
    > ##D plot(mymap,add=TRUE)
    > ## End(Not run)
    > plot(myPoints,col = as.character(cut(
    + myPoints$y1, breaks, thecol
    + )),add=TRUE)
    > scaleBar(myPoints, "bottomright",cex=1.25, scale.cex=2)
    Warning in library(package, lib.loc = lib.loc, character.only = TRUE, logical.return = TRUE, :
     there is no package called ‘rgdal’
    Error in spTransform(xpoints, CRSobj = crsLL) :
     load package rgdal for spTransform methods
    Calls: scaleBar -> spTransform -> spTransform
    Execution halted
Flavor: r-release-osx-x86_64-mavericks