CRAN Package Check Results for Package multilevelPSA

Last updated on 2014-04-25 05:47:20.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.2 2.32 29.76 32.09 NOTE
r-devel-linux-x86_64-debian-gcc 1.2 2.12 29.54 31.66 NOTE
r-devel-linux-x86_64-fedora-clang 1.2 63.51 NOTE
r-devel-linux-x86_64-fedora-gcc 1.2 60.70 NOTE
r-devel-osx-x86_64-clang 1.2 66.69 NOTE
r-devel-osx-x86_64-gcc 1.2 ERROR
r-devel-windows-ix86+x86_64 1.2 6.00 43.00 49.00 NOTE
r-patched-linux-x86_64 1.2 2.10 29.30 31.39 NOTE
r-patched-solaris-sparc 1.2 372.20 NOTE
r-patched-solaris-x86 1.2 84.90 NOTE
r-release-linux-ix86 1.2 4.00 55.00 59.00 NOTE
r-release-linux-x86_64 1.2 2.12 29.41 31.53 NOTE
r-release-osx-x86_64-mavericks 1.2 WARN
r-release-osx-x86_64-snowleopard 1.2 NOTE
r-release-windows-ix86+x86_64 1.2 9.00 48.00 57.00 NOTE
r-oldrel-windows-ix86+x86_64 1.2 8.00 50.00 58.00 NOTE

Check Details

Version: 1.2
Check: package dependencies
Result: NOTE
    Depends: includes the non-default packages:
     ‘ggplot2’ ‘plyr’ ‘psych’ ‘reshape’ ‘proto’ ‘grid’ ‘xtable’
    Adding so many packages to the search path is excessive and importing
    selectively is preferable.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-snowleopard, r-release-windows-ix86+x86_64

Version: 1.2
Check: DESCRIPTION meta-information
Result: NOTE
    Package listed in more than one of Depends, Imports, Suggests, Enhances:
     ‘xtable’
    A package should be listed in only one of these fields.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-mavericks, r-release-osx-x86_64-snowleopard, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.2
Check: dependencies in R code
Result: NOTE
    Packages in Depends field not imported from:
     ‘ggplot2’ ‘plyr’ ‘psych’ ‘reshape’
     These packages need to be imported from (in the NAMESPACE file)
     for when this namespace is loaded but not attached.
    Unexported object imported by a ':::' call: ‘ggplot2:::.zeroGrob’
     See the note in ?`:::` about the use of this operator.
    There are ::: calls to the package's namespace in its code. A package
     almost never needs to use ::: for its own objects:
     ‘align.plots’
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-devel-osx-x86_64-clang, r-devel-windows-ix86+x86_64, r-patched-linux-x86_64, r-patched-solaris-sparc, r-patched-solaris-x86, r-release-linux-ix86, r-release-linux-x86_64, r-release-osx-x86_64-mavericks, r-release-windows-ix86+x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.2
Check: package dependencies
Result: ERROR
    Package required but not available: ‘ggplot2’
    
    Package suggested but not available for checking: ‘party’
    
    Depends: includes the non-default packages:
     ‘ggplot2’ ‘plyr’ ‘psych’ ‘reshape’ ‘proto’ ‘grid’ ‘xtable’
    Adding so many packages to the search path is excessive and importing
    selectively is preferable.
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-devel-osx-x86_64-gcc

Version: 1.2
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘party’
    
    Depends: includes the non-default packages:
     ‘ggplot2’ ‘plyr’ ‘psych’ ‘reshape’ ‘proto’ ‘grid’ ‘xtable’
    Adding so many packages to the search path is excessive and importing
    selectively is preferable.
Flavor: r-release-osx-x86_64-mavericks

Version: 1.2
Check: R code for possible problems
Result: NOTE
    getStrata: no visible global function definition for ‘where’
    mlpsa.ctree : partyPlyr: no visible global function definition for
     ‘ctree’
    tree.plot : convertTree: no visible global function definition for
     ‘nodes’
Flavor: r-release-osx-x86_64-mavericks

Version: 1.2
Check: PDF version of manual
Result: WARNING
    LaTeX errors when creating PDF version.
    This typically indicates Rd problems.
    LaTeX errors found:
    ! LaTeX Error: File `upquote.sty' not found.
    
    Type X to quit or <RETURN> to proceed,
    or enter new name. (Default extension: sty)
    
    6ed9dde/Rd2.tex:8: ==> Fatal error occurred, no output PDF file produced!
Flavor: r-release-osx-x86_64-mavericks

Version: 1.2
Check: dependencies in R code
Result: NOTE
    Packages in Depends field not imported from:
     'ggplot2' 'plyr' 'psych' 'reshape'
     These packages need to be imported from for the case when
     this namespace is loaded but not attached.
    Unexported object imported by a ':::' call: 'ggplot2:::.zeroGrob'
     See the note in ?`:::` about the use of this operator.
    There are ::: calls to the package's namespace in its code. A package
     almost never needs to use ::: for its own objects:
     'align.plots'
    See the information on DESCRIPTION files in the chapter 'Creating R
    packages' of the 'Writing R Extensions' manual.
Flavor: r-release-osx-x86_64-snowleopard