CRAN Package Check Results for Package npbr

Last updated on 2018-02-23 14:49:35 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.6 7.13 126.93 134.06 NOTE
r-devel-linux-x86_64-debian-gcc 1.6 6.18 101.32 107.50 NOTE
r-devel-linux-x86_64-fedora-clang 1.6 168.16 NOTE
r-devel-linux-x86_64-fedora-gcc 1.6 162.90 NOTE
r-devel-windows-ix86+x86_64 1.6 19.00 218.00 237.00 ERROR
r-patched-linux-x86_64 1.6 5.67 128.56 134.23 OK
r-patched-solaris-x86 1.6 227.10 OK
r-release-linux-x86_64 1.6 6.17 131.41 137.58 OK
r-release-windows-ix86+x86_64 1.6 20.00 227.00 247.00 OK
r-release-osx-x86_64 1.6 ERROR
r-oldrel-windows-ix86+x86_64 1.6 12.00 160.00 172.00 OK
r-oldrel-osx-x86_64 1.6 OK

Check Details

Version: 1.6
Check: DESCRIPTION meta-information
Result: NOTE
    Dependence on R version ‘3.3.1’ not with patchlevel 0
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.6
Check: running examples for arch ‘x64’
Result: ERROR
    Running examples in 'npbr-Ex.R' failed
    The error most likely occurred in:
    
    > ### Name: poly_est
    > ### Title: Polynomial frontier estimators
    > ### Aliases: poly_est
    > ### Keywords: optimize
    >
    > ### ** Examples
    >
    > data("air")
    > x.air <- seq(min(air$xtab), max(air$xtab),
    + length.out = 101)
    > # Optimal polynomial degrees via the AIC criterion
    > (p.aic.air <- poly_degree(air$xtab, air$ytab,
    + type = "AIC"))
    [1] 3
    > # Polynomial boundaries estimate
    > y.poly.air<-poly_est(air$xtab, air$ytab, x.air,
    + deg = p.aic.air)
    > # Representation
    > plot(x.air, y.poly.air, lty = 1, lwd = 4,
    + col = "magenta", type = "l")
    Warning in min(x) : no non-missing arguments to min; returning Inf
    Warning in max(x) : no non-missing arguments to max; returning -Inf
    Error in plot.window(...) : need finite 'ylim' values
    Calls: plot -> plot.default -> localWindow -> plot.window
    Execution halted
Flavor: r-devel-windows-ix86+x86_64

Version: 1.6
Check: package dependencies
Result: ERROR
    Package required but not available: ‘Rglpk’
    
    See section ‘The DESCRIPTION file’ in the ‘Writing R Extensions’
    manual.
Flavor: r-release-osx-x86_64