CRAN Package Check Results for Package optparse

Last updated on 2016-08-27 23:48:17.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.3.2 0.60 14.87 15.47 OK
r-devel-linux-x86_64-debian-gcc 1.3.2 0.64 13.99 14.63 OK
r-devel-linux-x86_64-fedora-clang 1.3.2 26.68 OK
r-devel-linux-x86_64-fedora-gcc 1.3.2 25.28 OK
r-devel-osx-x86_64-clang 1.3.2 22.43 WARN
r-devel-windows-ix86+x86_64 1.3.2 3.00 34.00 37.00 WARN
r-patched-linux-x86_64 1.3.2 0.59 14.21 14.80 OK
r-patched-solaris-sparc 1.3.2 148.50 WARN
r-patched-solaris-x86 1.3.2 34.50 WARN
r-release-linux-x86_64 1.3.2 0.64 14.49 15.12 OK
r-release-osx-x86_64-mavericks 1.3.2 WARN
r-release-windows-ix86+x86_64 1.3.2 4.00 32.00 36.00 WARN
r-oldrel-windows-ix86+x86_64 1.3.2 3.00 52.00 55.00 NOTE

Check Details

Version: 1.3.2
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Traceback (most recent call last):
     File "/usr/local/bin/rst2pdf", line 5, in <module>
     from pkg_resources import load_entry_point
     File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 2797, in <module>
     parse_requirements(__requires__), Environment()
     File "/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python/pkg_resources.py", line 580, in resolve
     raise VersionConflict(dist,req) # XXX put more info here
    pkg_resources.VersionConflict: (setuptools 1.1.6 (/System/Library/Frameworks/Python.framework/Versions/2.7/Extras/lib/python), Requirement.parse('setuptools>=2.2'))
    Error: processing vignette 'optparse.Rrst' failed with diagnostics:
    conversion by rst2pdf failed!
    Execution halted
Flavor: r-devel-osx-x86_64-clang

Version: 1.3.2
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning: running command '"rst2pdf" "optparse.rst" -o "optparse.pdf" ' had status 127
    Error: processing vignette 'optparse.Rrst' failed with diagnostics:
    conversion by rst2pdf failed!
    Execution halted
Flavors: r-devel-windows-ix86+x86_64, r-release-windows-ix86+x86_64

Version: 1.3.2
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    sh: rst2pdf: not found
    Error: processing vignette 'optparse.Rrst' failed with diagnostics:
    conversion by rst2pdf failed!
    Execution halted
Flavors: r-patched-solaris-sparc, r-patched-solaris-x86

Version: 1.3.2
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    sh: rst2pdf: command not found
    Error: processing vignette 'optparse.Rrst' failed with diagnostics:
    conversion by rst2pdf failed!
    Execution halted
Flavor: r-release-osx-x86_64-mavericks

Version: 1.3.2
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    Warning: running command '"rst2pdf" "optparse.rst" -o "optparse.pdf" ' had status 127
    Error: processing vignette 'optparse.Rrst' failed with diagnostics:
    conversion by rst2pdf failed!
    Execution halted
Flavor: r-oldrel-windows-ix86+x86_64