CRAN Package Check Results for Package planar

Last updated on 2014-04-23 12:48:24.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.5 12.96 26.23 39.19 OK
r-devel-linux-x86_64-debian-gcc 1.5 15.85 25.96 41.81 OK
r-devel-linux-x86_64-fedora-clang 1.5 82.95 WARN
r-devel-linux-x86_64-fedora-gcc 1.5 82.92 WARN
r-devel-osx-x86_64-clang 1.5 84.23 OK
r-devel-osx-x86_64-gcc 1.5 ERROR
r-devel-windows-ix86+x86_64 1.5 42.00 60.00 102.00 OK
r-patched-linux-x86_64 1.5 15.95 26.12 42.07 OK
r-patched-solaris-sparc 1.5 475.50 OK
r-patched-solaris-x86 1.5 106.30 OK
r-release-linux-ix86 1.5 24.00 52.00 76.00 OK
r-release-linux-x86_64 1.5 16.12 26.04 42.17 OK
r-release-osx-x86_64-mavericks 1.5 WARN
r-release-osx-x86_64-snowleopard 1.5 WARN
r-release-windows-ix86+x86_64 1.5 44.00 59.00 103.00 OK
r-oldrel-windows-ix86+x86_64 1.5 46.00 61.00 107.00 OK

Check Details

Version: 1.5
Check: sizes of PDF files under ‘inst/doc’
Result: WARNING
     ‘gs+qpdf’ made some significant size reductions:
     compacted ‘fresnel.pdf’ from 404Kb to 79Kb
     consider running tools::compactPDF(gs_quality = "ebook") on these files
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 1.5
Check: package dependencies
Result: ERROR
    Package required but not available: ‘dielectric’
    
    Packages suggested but not available for checking:
     ‘ggplot2’ ‘Hmisc’ ‘gridExtra’ ‘knitr’
    
    Files named as vignettes but with no recognized vignette engine:
     ‘inst/doc/decay_rates.Rnw’
     ‘inst/doc/fresnel.rnw’
     ‘inst/doc/gaussian.rnw’
    (Is a VignetteBuilder field missing?)
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-devel-osx-x86_64-gcc

Version: 1.5
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    Warning: running command 'kpsewhich framed.sty' had status 1
    Warning in test_latex_pkg("framed", system.file("misc", "framed.sty", package = "knitr")) :
     unable to find LaTeX package 'framed'; will use a copy from knitr
    Error in texi2dvi(file = file, pdf = TRUE, clean = clean, quiet = quiet, :
     Running 'texi2dvi' on 'fresnel.tex' failed.
    LaTeX errors:
    ! LaTeX Error: File `titlesec.sty' not found.
    
    Type X to quit or <RETURN> to proceed,
    or enter new name. (Default extension: sty)
    
    test/planar/vignettes/fresnel.tex:58: ==> Fatal error occurred, no output PDF
    file produced!
    Calls: buildVignettes -> texi2pdf -> texi2dvi
    Execution halted
Flavor: r-release-osx-x86_64-mavericks

Version: 1.5
Check: PDF version of manual
Result: WARNING
    LaTeX errors when creating PDF version.
    This typically indicates Rd problems.
    LaTeX errors found:
    ! LaTeX Error: File `upquote.sty' not found.
    
    Type X to quit or <RETURN> to proceed,
    or enter new name. (Default extension: sty)
    
    55910ad/Rd2.tex:8: ==> Fatal error occurred, no output PDF file produced!
Flavor: r-release-osx-x86_64-mavericks

Version: 1.5
Check: examples
Result: WARNING
    checking a package with encoding 'UTF-8' in an ASCII locale
    
     OK
Flavor: r-release-osx-x86_64-snowleopard

Version: 1.5
Check: re-building of vignette outputs
Result: NOTE
    Error in re-building vignettes:
     ...
    Warning: running command 'kpsewhich framed.sty' had status 1
    Warning in test_latex_pkg("framed", system.file("misc", "framed.sty", package = "knitr")) :
     unable to find LaTeX package 'framed'; will use a copy from knitr
    Error in texi2dvi(file = file, pdf = TRUE, clean = clean, quiet = quiet, :
     Running 'texi2dvi' on 'fresnel.tex' failed.
    LaTeX errors:
    ! LaTeX Error: File `titlesec.sty' not found.
    
    Type X to quit or <RETURN> to proceed,
    or enter new name. (Default extension: sty)
    
    planar.Rcheck/vign_test/planar/vignettes/fresnel.tex:58: ==> Fatal error occur
    red, no output PDF file produced!
    Calls: buildVignettes -> texi2pdf -> texi2dvi
    Execution halted
Flavor: r-release-osx-x86_64-snowleopard