CRAN Package Check Results for Package plotGoogleMaps

Last updated on 2014-04-25 05:47:21.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 2.0 1.85 40.87 42.72 OK
r-devel-linux-x86_64-debian-gcc 2.0 1.79 40.38 42.17 OK
r-devel-linux-x86_64-fedora-clang 2.0 87.58 NOTE
r-devel-linux-x86_64-fedora-gcc 2.0 84.24 NOTE
r-devel-osx-x86_64-clang 2.0 81.32 OK
r-devel-osx-x86_64-gcc 2.0 ERROR
r-devel-windows-ix86+x86_64 2.0 6.00 66.00 72.00 OK
r-patched-linux-x86_64 2.0 1.86 40.20 42.06 OK
r-patched-solaris-sparc 2.0 472.30 OK
r-patched-solaris-x86 2.0 117.40 OK
r-release-linux-ix86 2.0 3.00 68.00 71.00 OK
r-release-linux-x86_64 2.0 1.93 40.90 42.82 OK
r-release-osx-x86_64-mavericks 2.0 ERROR
r-release-osx-x86_64-snowleopard 2.0 OK
r-release-windows-ix86+x86_64 2.0 8.00 67.00 75.00 OK
r-oldrel-windows-ix86+x86_64 2.0 7.00 68.00 75.00 OK

Check Details

Version: 2.0
Check: Rd line widths
Result: NOTE
    Rd file 'PolyCol.Rd':
     \examples lines wider than 100 characters:
     m<-plotGoogleMaps(meuse,zcol='zinc',at=c(0,300,600, max(meuse$zinc)), colPalette=rainbow(3), filename='myMap_z4.htm')
    
    Rd file 'bubbleGoogleMaps.Rd':
     \examples lines wider than 100 characters:
     m<-bubbleGoogleMaps(meuse,zcol='cadmium',filename='myMapCadmium.htm',layerName='Bubble plot - meuse',colPalette=terrain.colors(5),strok ... [TRUNCATED]
    
    Rd file 'bubbleSP.Rd':
     \examples lines wider than 100 characters:
     wind<-data.frame( Station=c('Zlatibor' , 'Sjenica' , 'Pozega' , 'Kraljevo', 'Kopaonik', 'Kursumlija', 'Krusevac'),
     Lon=c(19.708418 , 19.999311 , 20.029322, 20.724012, 20.776111, 21.279513, 21.307998 ),
     Lat=c(43.729755 , 43.267913 ,43.84859 ,43.726812 ,43.2725, 43.137053 ,43.574188),
    
    Rd file 'elSPDF.Rd':
     \examples lines wider than 100 characters:
     ell<- data.frame(E=c(7456263,7456489,7456305),N=c(4954146,4952978,4952695),A=c( 2.96,4.55,7.10),B=c(2.35,2.11,2.29),teta=c(28.35242 ... [TRUNCATED]
     proj4string(ell) <- CRS("+proj=tmerc +lat_0=0 +lon_0=21 +k=0.9999 +x_0=7500000 +y_0=0 +ellps=bessel +towgs84=574.027,170.175,401.54 ... [TRUNCATED]
    
    Rd file 'ellipseGoogleMaps.Rd':
     \examples lines wider than 100 characters:
     ell<- data.frame(E=c(7456263,7456489,7456305),N=c(4954146,4952978,4952695),A=c( 2.96,4.55,7.10),B=c(2.35,2.11,2.29),teta=c(28.35242 ... [TRUNCATED]
     proj4string(ell) <- CRS("+proj=tmerc +lat_0=0 +lon_0=21 +k=0.9999 +x_0=7500000 +y_0=0 +ellps=bessel +towgs84=574.027,170.175,401.54 ... [TRUNCATED]
    
    Rd file 'iconlabels.Rd':
     \examples lines wider than 100 characters:
     m<-plotGoogleMaps(meuse,zcol='landuse',colPalette=rainbow(15), filename='myMap_lu.htm', iconMarker=ic)
     m<-plotGoogleMaps(meuse,zcol='landuse',colPalette='#9ECAE1', filename='myMap_lu2.htm', iconMarker=ic)
    
    Rd file 'stplotGoogleMaps.Rd':
     \usage lines wider than 90 characters:
     key.entries = if(do.bubble){quantile(SPT@data[,zcol],(1:5)/5, na.rm=T)}else{0},
     \examples lines wider than 100 characters:
     # stplotGoogleMaps(HRtemp08_jan,zcol='TEMP',stfilename='HR_temp.html', mapTypeId='ROADMAP',w='49%',h='49%', strokeOpacity = 0,
     #ee= stplotGoogleMaps(Produc.st,zcol='unemp',stfilename='USA.htm',colPalette=brewer.pal(9, "YlOrRd"), mapTypeId='ROADMAP',
     # ee= stplotGoogleMaps(Produc.st,zcol='unemp',stfilename='USA2.htm',colPalette=brewer.pal(9, "YlOrRd"),
    
    Rd file 'vectorsSP.Rd':
     \examples lines wider than 100 characters:
     wind<-data.frame( Station=c('Zlatibor' , 'Sjenica' , 'Pozega' , 'Kraljevo', 'Kopaonik', 'Kursumlija', 'Krusevac'),
     Lon=c(19.708418 , 19.999311 , 20.029322, 20.724012, 20.776111, 21.279513, 21.307998 ),
     Lat=c(43.729755 , 43.267913 ,43.84859 ,43.726812 ,43.2725, 43.137053 ,43.574188),
    
    These lines will be truncated in the PDF manual.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 2.0
Check: package dependencies
Result: ERROR
    Package required but not available: ‘maptools’
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-devel-osx-x86_64-gcc

Version: 2.0
Check: package dependencies
Result: ERROR
    Packages required but not available: ‘rgdal’ ‘maptools’
    
    See the information on DESCRIPTION files in the chapter ‘Creating R
    packages’ of the ‘Writing R Extensions’ manual.
Flavor: r-release-osx-x86_64-mavericks