CRAN Package Check Results for Package polysat

Last updated on 2015-05-23 17:48:51.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.3-3 1.71 43.99 45.70 OK
r-devel-linux-x86_64-debian-gcc 1.3-3 1.64 43.60 45.24 OK
r-devel-linux-x86_64-fedora-clang 1.3-3 92.79 OK
r-devel-linux-x86_64-fedora-gcc 1.3-3 88.87 OK
r-devel-osx-x86_64-clang 1.3-3 86.66 OK
r-devel-windows-ix86+x86_64 1.3-3 5.00 67.00 72.00 OK
r-patched-linux-x86_64 1.3-3 1.75 43.97 45.72 OK
r-patched-solaris-sparc 1.3-3 592.70 OK
r-patched-solaris-x86 1.3-3 111.30 OK
r-release-linux-x86_64 1.3-3 1.99 44.62 46.60 OK
r-release-osx-x86_64-mavericks 1.3-3 OK
r-release-osx-x86_64-snowleopard 1.3-3 ERROR
r-release-windows-ix86+x86_64 1.3-3 6.00 70.00 76.00 OK
r-oldrel-windows-ix86+x86_64 1.3-3 5.00 73.00 78.00 OK

Check Details

Version: 1.3-3
Check: package dependencies
Result: NOTE
    Package suggested but not available for checking: ‘adegenet’
Flavor: r-release-osx-x86_64-snowleopard

Version: 1.3-3
Check: examples
Result: ERROR
    Running examples in ‘polysat-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: gendata.to.genind
    > ### Title: Convert Data to genind Format
    > ### Aliases: gendata.to.genind
    > ### Keywords: manip
    >
    > ### ** Examples
    >
    > # create a "genambig" object
    > mydata <- new("genambig", samples=c("a","b","c","d"), loci=c("e","f"))
    > PopNames(mydata) <- c("G","H")
    > PopInfo(mydata) <- c(1,1,2,2)
    > mydata <- reformatPloidies(mydata, output="one")
    > Ploidies(mydata) <- 3
    > Genotypes(mydata, loci="e") <- list(c(100),c(100,102),
    + c(98,102,104),c(102,106))
    > Genotypes(mydata, loci="f") <- list(c(200,202,204),Missing(mydata),
    + c(210,212),c(204,210,214))
    >
    > # convert to "genind"
    > mydata2 <- gendata.to.genind(mydata)
    Error in loadNamespace(name) : there is no package called ‘adegenet’
    Calls: gendata.to.genind ... tryCatch -> tryCatchList -> tryCatchOne -> <Anonymous>
    Execution halted
Flavor: r-release-osx-x86_64-snowleopard