automagic: Automagically Document and Install Packages Necessary to Run R Code

Parse R code in a given directory for R packages and attempt to install them from CRAN or GitHub. Optionally use a dependencies file for tighter control over which package versions to install.

Version: 0.3
Depends: R (≥ 3.1.0)
Imports: knitr, formatR, pacman, githubinstall, magrittr, dplyr, purrr, devtools, remotes, yaml
Published: 2017-02-26
Author: Cole Brokamp
Maintainer: Cole Brokamp <cole.brokamp at>
License: GPL-2 | GPL-3 [expanded from: GPL]
NeedsCompilation: no
Materials: README
CRAN checks: automagic results


Reference manual: automagic.pdf
Package source: automagic_0.3.tar.gz
Windows binaries: r-devel:, r-release:, r-oldrel:
OS X El Capitan binaries: r-release: automagic_0.3.tgz
OS X Mavericks binaries: r-oldrel: automagic_0.3.tgz


Please use the canonical form to link to this page.