CRAN Package Check Results for Package link2GI

Last updated on 2020-02-18 07:49:51 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.4.1 10.37 82.73 93.10 WARN
r-devel-linux-x86_64-debian-gcc 0.4.1 9.23 63.04 72.27 WARN
r-devel-linux-x86_64-fedora-clang 0.4.1 114.03 WARN
r-devel-linux-x86_64-fedora-gcc 0.4.1 113.80 WARN
r-devel-windows-ix86+x86_64 0.4.1 25.00 95.00 120.00 OK
r-devel-windows-ix86+x86_64-gcc8 0.4.1 51.00 143.00 194.00 OK
r-patched-linux-x86_64 0.4.1 9.60 74.93 84.53 OK
r-patched-solaris-x86 0.4.1 161.80 NOTE
r-release-linux-x86_64 0.4.1 9.99 73.73 83.72 OK
r-release-windows-ix86+x86_64 0.4.1 19.00 88.00 107.00 OK
r-release-osx-x86_64 0.4.1 NOTE
r-oldrel-windows-ix86+x86_64 0.4.1 14.00 125.00 139.00 OK
r-oldrel-osx-x86_64 0.4.1 NOTE

Check Details

Version: 0.4.1
Check: data for non-ASCII characters
Result: WARN
     Error loading dataset 'rgb':
     Error in .requirePackage(package) :
     unable to find required package 'raster'
    
     The dataset(s) may use package(s) not declared in Depends/Imports.
Flavors: r-devel-linux-x86_64-debian-clang, r-devel-linux-x86_64-debian-gcc, r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc

Version: 0.4.1
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘methods’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64