CRAN Package Check Results for Package ztable

Last updated on 2019-03-23 11:51:37 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 0.2.0 6.90 66.55 73.45 OK
r-devel-linux-x86_64-debian-gcc 0.2.0 6.27 58.18 64.45 OK
r-devel-linux-x86_64-fedora-clang 0.2.0 121.46 NOTE
r-devel-linux-x86_64-fedora-gcc 0.2.0 79.07 NOTE
r-devel-windows-ix86+x86_64 0.2.0 28.00 152.00 180.00 OK
r-patched-linux-x86_64 0.2.0 6.23 65.69 71.92 OK
r-patched-solaris-x86 0.2.0 128.00 WARN
r-release-linux-x86_64 0.2.0 0.37 1.95 2.32 ERROR
r-release-windows-ix86+x86_64 0.2.0 13.00 105.00 118.00 OK
r-release-osx-x86_64 0.2.0 WARN
r-oldrel-windows-ix86+x86_64 0.2.0 13.00 159.00 172.00 OK
r-oldrel-osx-x86_64 0.2.0 WARN

Check Details

Version: 0.2.0
Check: dependencies in R code
Result: NOTE
    Namespace in Imports field not imported from: ‘moonBook’
     All declared Imports should be used.
Flavors: r-devel-linux-x86_64-fedora-clang, r-devel-linux-x86_64-fedora-gcc, r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.2.0
Check: re-building of vignette outputs
Result: WARN
    Error in re-building vignettes:
     ...
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Loading required package: moonBook
    Welcome to package ztable ver 0.2.0
    Warning in engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Quitting from lines 103-108 (ztable_update.Rmd)
    Error: processing vignette 'ztable_update.Rmd' failed with diagnostics:
    `render_flextable` needs to be used as a renderer for a knitr/rmarkdown R code chunk (render by rmarkdown)
    In addition: Warning message:
    In engine$weave(file, quiet = quiet, encoding = enc) :
     Pandoc (>= 1.12.3) and/or pandoc-citeproc not available. Falling back to R Markdown v1.
    Execution halted
Flavors: r-patched-solaris-x86, r-release-osx-x86_64, r-oldrel-osx-x86_64

Version: 0.2.0
Check: whether package can be installed
Result: ERROR
    Installation failed.
Flavor: r-release-linux-x86_64