automagic: Automagically Document and Install Packages Necessary to Run R Code

Parse R code in a given directory for R packages and attempt to install them from CRAN or GitHub. Optionally use a dependencies file for tighter control over which package versions to install.

Version: 0.3
Depends: R (≥ 3.1.0)
Imports: knitr, formatR, pacman, githubinstall, magrittr, dplyr, purrr, devtools, remotes, yaml
Published: 2017-02-26
Author: Cole Brokamp
Maintainer: Cole Brokamp <cole.brokamp at gmail.com>
BugReports: https://github.com/cole-brokamp/automagic/issues
License: GPL-2 | GPL-3 [expanded from: GPL]
URL: https://github.com/cole-brokamp/automagic
NeedsCompilation: no
Materials: README
CRAN checks: automagic results

Downloads:

Reference manual: automagic.pdf
Package source: automagic_0.3.tar.gz
Windows binaries: r-devel: automagic_0.3.zip, r-release: automagic_0.3.zip, r-oldrel: automagic_0.3.zip
OS X Mavericks binaries: r-release: automagic_0.3.tgz, r-oldrel: automagic_0.3.tgz

Linking:

Please use the canonical form https://CRAN.R-project.org/package=automagic to link to this page.