fpp3

CRAN status Travis build status

Overview

The fpp3 package contains data used in the book Forecasting: Principles and Practice (3rd edition) by Rob J Hyndman and George Athanasopoulos. It also loads several packages needed to do the analysis described in the book. These packages work with the tidyverse set of packages, sharing common data representations and API design.

Installation

You can install the stable version from CRAN.

install.packages('fpp3', dependencies = TRUE)

You can install the development version from Github

# install.packages("remotes")
remotes::install_github("robjhyndman/fpp3-package")

Usage

library(fpp3) will load the following packages:

You also get a condensed summary of conflicts with other packages you have loaded:

library(fpp3)
#> ── Attaching packages ─────────────────────────────────────────────────────────────── fpp3 0.1 ──
#> ✔ tibble      2.1.3          ✔ tsibble     0.8.4     
#> ✔ dplyr       0.8.3          ✔ tsibbledata 0.1.0.9000
#> ✔ tidyr       1.0.0          ✔ feasts      0.1.1.9000
#> ✔ lubridate   1.7.4          ✔ fable       0.1.0.9000
#> ✔ ggplot2     3.2.1
#> ── Conflicts ────────────────────────────────────────────────────────────────── fpp3_conflicts ──
#> ✖ lubridate::date()       masks base::date()
#> ✖ dplyr::filter()         masks stats::filter()
#> ✖ tsibble::id()           masks dplyr::id()
#> ✖ tsibble::interval()     masks lubridate::interval()
#> ✖ dplyr::lag()            masks stats::lag()
#> ✖ tsibble::new_interval() masks lubridate::new_interval()