Project Status: Active – The project has reached a stable, usable state and is being actively developed. Travis-CI Build Status CRAN version GitHub last commit License

link2GI

link2GI provide some functions which make it a bit easier to connect straightforward the common open source GI software packages to the R-biotop. It supports both the use of wrapper packages and the direct API-use via system calls. It focuses on Linux and WindowsX operating systems but nevertheless it should also work with OSX.

To utilize the power of the open source GI tools from within R you need to install them first. As a first promising opportunity to do fullfil most of the requirements you may install QGIS, GRASS- and SAGA-GIS following the excellent installation instructions of the RQGIS package will have a good first try to ensure a smooth working environment. Note: for most of the cases you may use just RQGIS as wrapper for the QGIS related functionality.

If you have several versions installed or if you want to use the full power of the GI software it will be a nice and helpful tool to deal with some strange behaviours and requirements. Especially helpful is the support of OTB, the GDAL-Python functions and a simple support to use any SAGA version via the CLI. Hopefully RSAGA and Rsagacmd will join forces in one package in the future. Anyway the brand new release 1.2.0 of RSAGA as well as the current Rsagacmd will work with the environment settings as provided by linkSAGA.

Installation

link2GIis up to CRAN. For the installation of the stable version please use install.packages("link2GI"). To install the cutting edge version use devtools::install_github("gisma/link2GI", ref = "master").

Usecases presented on the GEOSTAT August 2018

During the GEOSTAT 2018 in Prague some more complex usescases has been presented.

Find slides and materials

GEOSTAT 2018 presentation slides.

link2GI GEOSTAT github repository.

Prerequisites

Please check the R dependencies:

```{r, eval=FALSE} install.packages(c(“sf”, “raster”, “rgdal”, “gdalUtils”, “tools”, “rgrass7”, “sp”, “RSAGA”, “link2GI”))

for the Canopy height model usecase you need to install uavRst

devtools::install_github(“gisma/uavRst”, ref = “master”) ```

In addition you need at least one installation of the following GIS software.

Please download the data and scripts for the exercises.

PLEASE NOTE:

If you run the following code you will create the folder link2gi-master in your home folder. During the tutorial it is assumed to be the root folder.

{r, eval=FALSE} url <- "https://github.com/gisma/link2gi2018/archive/master.zip" res <- curl::curl_download(url, paste0(tmpDir(),"master.zip")) utils::unzip(zipfile = res, exdir = "~")

The examples